Build Status Coverage Status Scrutinizer Code Quality PyPI Version PyPI Downloads

Overview

GitMan is a language-agnostic "dependency manager" using Git. It aims to serve as a submodules replacement and provides advanced options for managing versions of nested Git repositories.

Setup

Requirements

  • Python 3.5+
  • Git 1.8+ (with stored credentials)
  • Unix shell (or Cygwin/MinGW/etc. on Windows)

Installation

GitMan can be installed with pip:

$ pip install gitman

or directly from the source code:

$ git clone https://github.com/jacebrowning/gitman.git
$ cd gitman
$ python setup.py install

Setup

Create a configuration file (gitman.yml or .gitman.yml) in the root of your working tree:

location: vendor
sources:
- name: framework
  repo: https://github.com/kstenerud/iOS-Universal-Framework
  rev: Mk5-end-of-life
- name: coverage
  repo: https://github.com/jonreid/XcodeCoverage
  rev: master
  link: Tools/XcodeCoverage

Ignore the dependency storage location:

$ echo vendor >> .gitignore

Usage

See the available commands:

$ gitman --help

Updating Dependencies

Get the latest versions of all dependencies:

$ gitman update

which will essentially:

  1. create a working tree at (root)/<location>/<name>
  2. fetch from repo and checkout the specified rev
  3. symbolically link each <location>/<name> from (root)/<link> (if specified)
  4. repeat for all nested working trees containing a configuration file
  5. record the actual commit SHAs that were checked out (with --lock option)

where rev can be:

  • all or part of a commit SHA: 123def
  • a tag: v1.0
  • a branch: master
  • a rev-parse date: 'develop@{2015-06-18 10:30:59}'

Restoring Previous Versions

Display the specific revisions that are currently installed:

$ gitman list

Reinstall these specific versions at a later time:

$ gitman install

Deleting Dependencies

Remove all installed dependencies:

$ gitman uninstall